Skip to content

Unsupported query parameter sslmode #265

Description

@darraghenright

HI there.

This is really just a question at this point.

I deployed a Phoenix/Commanded app to Fly this evening. Fly makes a PG connection string available as an envvar named DATABASE_URL. I used this to configure the EventStore database.

It failed with the following error because of the presence of sslmode in the connection string:

shutdown: failed to start child: CRM.EventStore
        ** (EXIT) an exception was raised:
            ** (ArgumentError) unsupported query parameter `sslmode`
                (eventstore 1.4.1) lib/event_store/config/parser.ex:90: anonymous fn/2 in EventStore.Config.Parser.parse_uri_query/1

A quick look at EventStore.Config.Parser.parse_uri_query/1 reveals that this mode is indeed not supported. Is this an option that should be supported, silently discarded, or continue to raise an exception?

Cheers!

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions